【最新】【亲测有效】sublime 安装 emmet 失败的解决方法

【最新】【亲测有效】sublime 安装 emmet 失败的解决方法

写在前面

今天新电脑安装了一个最新的 sublime text 3,然后打算安装我喜爱的 Emmet 插件,结果:

难受啊 😥

可能的原因

一般是由于网速慢,或者目标域名被墙而无法正常访问导致的。

解决办法

步骤一

在 sublime 中点开 Preferences -> Package Settings -> Package Control -> Settings如下图


添加以下代码到 Package Control.sublime-settings — User 中:(ps: 注意格式)

"channels":
[
	"https://erhan.in/channel_v3.json"
],
"downloader_precedence":
{
	"linux":
	[
		"curl",
		"urllib",
		"wget"
	],
	"osx":
	[
		"curl",
		"urllib"
	],
	"windows":
	[
		"wininet"
	]
}

保存后,重启 sublime。再次尝试安装 Emmet 插件,如果没有意外,Emmet 将会安装成功,由于 Emmet 依赖 PyV8;然后,sublime 会去下载 PyV8,但此时可能会失败,报错。如下图:

难受 😥

步骤二

打开 PyV8 的 github 链接:https://github.com/emmetio/pyv8-binaries,并下载 PyV8压缩包。如下图:
在这里插入图片描述
根据你的电脑系统,找到对应的压缩包(这里以windows 64 位操作系统为例,就是 pyv8-win64-p3.zip),打开它,并复制里面的内容,如下图:
在这里插入图片描述
然后在 sublime 的 Installed Packages 文件夹中,新建 PyV8 文件夹(ps: 注意大小写),并粘贴进去。

Installed Packages 文件夹在哪?这个很关键】,我录了一小段 gif 演示图:
在这里插入图片描述
这样就找到了 Installed Packages 文件夹了,然后在里面新建 PyV8 文件夹(ps:gif 中可以看到我已经做了这一步),并将之前复制的内容粘贴到 PyV8 文件夹中,如下图:
在这里插入图片描述

重启 sublime,并尝试使用 emmet 语法,就可以啦~
在这里插入图片描述

ok,很好用。

-----------------(正文完)------------------

前端学习交流群,想进来面基的,可以加群:
Vue学习交流 React学习交流
或者手动search群号:685486827832485817


写在最后: 约定优于配置 —— 软件开发的简约原则
-------------------------------- (完)--------------------------------------

我的:
个人网站: https://neveryu.github.io/neveryu/
Github: https://github.com/Neveryu
新浪微博: https://weibo.com/Neveryu

更多学习资源请关注我的新浪微博…

相关推荐
©️2020 CSDN 皮肤主题: 编程工作室 设计师:CSDN官方博客 返回首页